Lua error in package.lua at line 80: module 'Dev:Arguments' not found.

Beast Killer in Final Fantasy V.

Lua error in package.lua at line 80: module 'Dev:Arguments' not found. Beast Killer Lua error in package.lua at line 80: module 'Dev:Arguments' not found., also known as Beastkill, is a recurring weapon in the series. It is often a mid to high-ranked whip that can inflict Paralysis on hit, and on occasion deals extra damage to Beast-type enemies.

Appearances[edit | edit source]

Final Fantasy V[edit | edit source]

Beast Killer is a mid to high-ranked whip that provides 72 Attack, 100 Hit Rate, a 50% chance to inflict Paralysis on Magic Beast-type enemies, and deals double damage to Magic Beast-type enemies. It can be found at Island Shrine or stolen from Iron Fist or Unknown (#168).

Final Fantasy Dimensions[edit | edit source]

Beast Killer is a mid to high-ranked whip that provides 53 Attack, 5 Hit Rate, and can inflict Paralysis. Lua error in package.lua at line 80: module 'Dev:Arguments' not found.

Final Fantasy Airborne Brigade[edit | edit source]

Lua error in package.lua at line 80: module 'Dev:Arguments' not found.

Final Fantasy All the Bravest[edit | edit source]

Beast Killer is a whip that provides 10 to attack and can be equipped by Beastmasters. Lua error in package.lua at line 80: module 'Dev:Arguments' not found.

Final Fantasy Record Keeper[edit | edit source]

Lua error in package.lua at line 80: module 'Dev:Arguments' not found.

Gallery[edit | edit source]

Whip - FF5.png
FFD Beast Killer.png
FFAB Beast Killer SSR.png
FFAB Beast Killer SSR+.png
Beast Killer ATB.png
FFRK Beast Killer FFIII.png
FFRK Beast Killer FFV.png
FFRK Beast Killer FFVIII.png

Lua error in package.lua at line 80: module 'Dev:Arguments' not found.

Lua error in package.lua at line 80: module 'Dev:NavboxBuilder' not found.

Community content is available under CC-BY-SA unless otherwise noted.